p PatchFirst

CVE-2025-0605

CVE-2025-0605 · Weak Authentication in GitLab

This page contains facts from public vulnerability sources. Check the original advisory before updating.

An issue has been discovered in GitLab CE/EE affecting all versions from 16.8 before 17.10.7, 17.11 before 17.11.3, and 18.0 before 18.0.1. Group access controls could allow certain users to bypass two-factor authentication requirements.

CVSS 4.6 · Medium · EPSS 0.3% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • gitlab

    Versions
    • ≥ 16.8, < 17.10.7: Affected (semver)
    • ≥ 17.11, < 17.11.3: Affected (semver)
    • ≥ 18.0, < 18.0.1: Affected (semver)

    Update to 17.10.7; Update to 17.11.3; Update to 18.0.1

  • gitlab Ubuntu:16.04:LTS

    Versions
    • 8.4.3+dfsg-9
    • 8.4.3+dfsg-12
    • 8.5.8+dfsg-5
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →