p PatchFirst

CVE-2025-0652

CVE-2025-0652 · Incorrect Authorization in GitLab

This page contains facts from public vulnerability sources. Check the original advisory before updating.

An issue has been discovered in GitLab EE/CE affecting all versions starting from 16.9 before 17.7.7, all versions starting from 17.8 before 17.8.5, all versions starting from 17.9 before 17.9.2 could allow unauthorized users to access confidential information intended for internal use only.

CVSS 4.3 · Medium · EPSS 0.4% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • gitlab

    Versions
    • ≥ 16.9, < 17.7.7: Affected (semver)
    • ≥ 17.8, < 17.8.5: Affected (semver)
    • ≥ 17.9, < 17.9.2: Affected (semver)

    Update to 17.7.7; Update to 17.8.5; Update to 17.9.2

  • gitlab Ubuntu:16.04:LTS

    Versions
    • 8.4.3+dfsg-9
    • 8.4.3+dfsg-12
    • 8.5.8+dfsg-5
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →