p PatchFirst

CVE-2025-0755

CVE-2025-0755 · MongoDB C Driver bson library may be susceptible to buffer overflow

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The various bson_append functions in the MongoDB C driver library may be susceptible to buffer overflow when performing operations that could result in a final BSON document which exceeds the maximum allowable size (INT32_MAX), resulting in a segmentation fault and possible application crash. This issue affected libbson versions prior to 1.27.5, MongoDB Server v8.0 versions prior to 8.0.1 and MongoDB Server v7.0 versions prior to 7.0.16

CVSS 8.4 · High · EPSS 0.8% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • libbson

    Versions
    • ≥ 0, < 1.27.5: Affected (custom)

    Update to 1.27.5

  • mongodb server

    Versions
    • ≥ 8.0, < 8.0.1: Affected (custom)
    • ≥ 7.0, < 7.0.16: Affected (custom)

    Update to 7.0.16; Update to 8.0.1

  • libbson-xs-perl Debian:12

    Versions
    • 0.8.4-2
    Affected ranges
    • ECOSYSTEM: < 0.8.4-2+deb12u1

    Update to 0.8.4-2+deb12u1

  • mongo-c-driver Debian:12

    Versions
    • 1.23.1-1
    Affected ranges
    • ECOSYSTEM: < 1.23.1-1+deb12u1

    Update to 1.23.1-1+deb12u1

  • mongo-c-driver Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.27.5-1

    Update to 1.27.5-1

  • mongo-c-driver Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.27.5-1

    Update to 1.27.5-1

  • mongo-c-driver Ubuntu:Pro:20.04:LTS

    Versions
    • 1.15.0-1
    • 1.15.1-1
    • 1.15.2-1
    • 1.16.0-1
    • 1.16.1-1
    • 1.16.1-1build1
    • 1.16.1-1build2
    • 1.16.1-1ubuntu0.1~esm1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • mongo-c-driver Ubuntu:22.04:LTS

    Versions
    • 1.18.0-1
    • 1.19.1-1
    • 1.19.2-1
    • 1.20.0-1
    • 1.20.0-1build1
    • 1.20.1-1
    • 1.21.0-1
    • 1.21.0-1build1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • mongo-c-driver Ubuntu:Pro:24.04:LTS

    Versions
    • 1.24.3-1
    • 1.24.4-1
    • 1.25.1-1
    • 1.25.2-1
    • 1.25.4-1
    • 1.26.0-1
    • 1.26.0-1.1ubuntu1
    • 1.26.0-1.1ubuntu2
    Affected ranges
    • ECOSYSTEM: < 1.26.0-1.1ubuntu2+esm1

    Update to 1.26.0-1.1ubuntu2+esm1

Original sources

Check your server →