p PatchFirst

CVE-2025-10923

CVE-2025-10923 · GIMP WBMP File Parsing Integer Overflow Remote Code Execution Vulnerability

This page contains facts from public vulnerability sources. Check the original advisory before updating.

GIMP WBMP File Parsing Integer Overflow Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of GIMP. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file. The specific flaw exists within the parsing of WBMP files. The issue results from the lack of proper validation of user-supplied data, which can result in an integer overflow before allocating a buffer. An attacker can leverage this vulnerability to execute code in the context of the current process. Was ZDI-CAN-27878.

CVSS 7.8 · High · EPSS 0.5% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • gimp

    Versions
    • 3.0.4: Affected

    No fix published

  • gimp Debian:13

    Versions
    • 3.0.4-3
    Affected ranges
    • ECOSYSTEM: < 3.0.4-3+deb13u1

    Update to 3.0.4-3+deb13u1

  • gimp Debian:14

    Versions
    • 3.0.4-3
    • 3.0.4-4
    • 3.0.4-5
    • 3.0.4-6
    Affected ranges
    • ECOSYSTEM: < 3.0.4-6.1

    Update to 3.0.4-6.1

Original sources

Check your server →