CVE-2025-11157
CVE-2025-11157 · Arbitrary Code Execution in feast-dev/feast
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A high-severity remote code execution vulnerability exists in feast-dev/feast version 0.53.0, specifically in the Kubernetes materializer job located at `feast/sdk/python/feast/infra/compute_engines/kubernetes/main.py`. The vulnerability arises from the use of `yaml.load(..., Loader=yaml.Loader)` to deserialize `/var/feast/feature_store.yaml` and `/var/feast/materialization_config.yaml`. This method allows for the instantiation of arbitrary Python objects, enabling an attacker with the ability to modify these YAML files to execute OS commands on the worker pod. This vulnerability can be exploited before the configuration is validated, potentially leading to cluster takeover, data poisoning, and supply-chain sabotage.
CVSS 7.8 · High · EPSS 0.3% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
feast-dev/feast
- Versions
- ≥ unspecified, < 0.54.0: Affected (custom)
Update to 0.54.0
feast PyPI
- Versions
- 0.1.0
- 0.1.0.post0
- 0.1.2
- 0.1.2.post0
- 0.1.2.post1
- 0.10.0
- 0.10.1
- 0.10.1rc1
- 0.10.1rc3
- 0.10.2
- 0.10.3
- 0.10.4
- 0.10.5
- 0.10.6
- 0.10.7
- 0.10.8
- 0.11.0
- 0.12.0
- 0.12.1
- 0.13.0
- 0.14.0
- 0.14.1
- 0.15.0
- 0.15.1
- 0.16.0
- 0.16.1
- 0.17.0
- 0.18.0
- 0.18.1
- 0.19.0
- 0.19.1
- 0.19.2
- 0.19.3
- 0.19.4
- 0.20.0
- 0.20.1
- 0.20.2
- 0.21.0
- 0.21.1
- 0.21.2
- 0.21.3
- 0.22.0
- 0.22.1
- 0.22.2
- 0.22.3
- 0.22.4
- 0.23.0
- 0.23.1
- 0.23.2
- 0.24.0
- 0.24.1
- 0.25.0
- 0.25.1
- 0.25.2
- 0.26.0
- 0.27.0
- 0.27.1
- 0.28.0
- 0.29.0
- 0.3.0
- 0.3.2
- 0.3.3
- 0.3.3.post0
- 0.3.4
- 0.3.5
- 0.3.6
- 0.3.7
- 0.30.2
- 0.31.0
- 0.31.1
- 0.33.1
- 0.34.0
- 0.34.1
- 0.35.0
- 0.36.0
- 0.37.1
- 0.38.0
- 0.39.0
- 0.39.1
- 0.4.0
- 0.4.1
- 0.4.1.post0
- 0.4.2
- 0.4.3
- 0.4.4
- 0.4.5
- 0.4.6
- 0.4.7
- 0.40.0
- 0.40.1
- 0.41.3
- 0.42.0
- 0.43.0
- 0.44.0
- 0.45.0
- 0.46.0
- 0.47.0
- 0.48.0
- 0.48.1
- 0.49.0
- 0.5.0
- 0.5.0.post0
- 0.5.0rc0
- 0.5.1
- 0.50.0
- 0.51.0
- 0.52.0
- 0.53.0
- 0.6.0
- 0.6.1
- 0.6.2
- 0.7.0
- 0.7.0rc1
- 0.7.0rc2
- 0.7.0rc3
- 0.7.1
- 0.7.2
- 0.8.0
- 0.8.0rc3
- 0.8.1
- 0.8.2
- 0.8.3
- 0.8.4
- 0.9.0
- 0.9.0rc1
- 0.9.0rc2
- 0.9.1
- 0.9.2
- 0.9.3
- 0.9.4
- 0.9.5
- 0.9.5.1
- 0.9.5.2
- 0.9.6
- 0.9.7
- 0.9.8
- 0.9.9
- Affected ranges
- ECOSYSTEM: < 0.54.0
Update to 0.54.0
Original sources
- https://huntr.com/bounties/46d4d585-b968-4a76-80ce-872bc5525564
- https://github.com/feast-dev/feast/commit/b2e37ff37953b68ae833f6874ab5bc510a4ca5fb
- https://access.redhat.com/security/cve/CVE-2025-11157
- https://bugzilla.redhat.com/show_bug.cgi?id=2426574
- https://security.access.redhat.com/data/csaf/v2/vex/2025/cve-2025-11157.json
- https://access.redhat.com/errata/RHSA-2026:10184
- https://nvd.nist.gov/vuln/detail/CVE-2025-11157