p PatchFirst

CVE-2025-11183

CVE-2025-11183 · Cross-Site Scripting Vulnerability in QWC2

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Cross-Site Scripting vulnerability in attribute table in QGIS QWC2 <2025.08.14 allows an authorized attacker to plant arbitrary JavaScript code in the page

CVSS 6.9 · Medium · EPSS 0.4% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • qwc2

    Versions
    • ≥ 0, < 2025.08.14: Affected (date)
    • 2025.08.14: Not affected (date)

    Update to 2025.08.14

  • qwc2 npm

    Affected ranges
    • ECOSYSTEM: < 2025.08.14

    Update to 2025.08.14

Original sources

Check your server →