p PatchFirst

CVE-2025-11200

CVE-2025-11200 · MLflow Weak Password Requirements Authentication Bypass Vulnerability

This page contains facts from public vulnerability sources. Check the original advisory before updating.

MLflow Weak Password Requirements Authentication Bypass Vulnerability. This vulnerability allows remote attackers to bypass authentication on affected installations of MLflow. Authentication is not required to exploit this vulnerability. The specific flaw exists within the handling of passwords. The issue results from weak password requirements. An attacker can leverage this vulnerability to bypass authentication on the system. Was ZDI-CAN-26916.

CVSS 8.1 · High · EPSS 1.4% · Fix available

Published
Updated

Stack: python

Affected products and versions

  • mlflow

    Versions
    • 2.21.0: Affected

    No fix published

  • mlflow PyPI

    Versions
    • 0.0.1
    • 0.1.0
    • 0.2.0
    • 0.2.1
    • 0.3.0
    • 0.4.0
    • 0.4.1
    • 0.4.2
    • 0.5.0
    • 0.5.1
    • 0.5.2
    • 0.6.0
    • 0.7.0
    • 0.8.0
    • 0.8.1
    • 0.8.2
    • 0.9.0
    • 0.9.0.1
    • 0.9.1
    • 1.0.0
    • 1.1.0
    • 1.1.1.dev0
    • 1.10.0
    • 1.11.0
    • 1.12.0
    • 1.12.1
    • 1.13
    • 1.13.1
    • 1.14.0
    • 1.14.1
    • 1.15.0
    • 1.16.0
    • 1.17.0
    • 1.18.0
    • 1.19.0
    • 1.2.0
    • 1.20.0
    • 1.20.1
    • 1.20.2
    • 1.21.0
    • 1.22.0
    • 1.23.0
    • 1.23.1
    • 1.24.0
    • 1.25.0
    • 1.25.1
    • 1.26.0
    • 1.26.1
    • 1.27.0
    • 1.28.0
    • 1.29.0
    • 1.3.0
    • 1.30.0
    • 1.30.1
    • 1.4.0
    • 1.5.0
    • 1.6.0
    • 1.7.0
    • 1.7.1
    • 1.7.2
    • 1.8.0
    • 1.9.0
    • 1.9.1
    • 2.0.0
    • 2.0.0rc0
    • 2.0.1
    • 2.1.0
    • 2.1.1
    • 2.10.0
    • 2.10.1
    • 2.10.2
    • 2.11.0
    • 2.11.1
    • 2.11.2
    • 2.11.3
    • 2.11.4
    • 2.12.0
    • 2.12.1
    • 2.12.2
    • 2.13.0
    • 2.13.1
    • 2.13.2
    • 2.14.0
    • 2.14.0rc0
    • 2.14.1
    • 2.14.2
    • 2.14.2.dev0
    • 2.14.3
    • 2.15.0
    • 2.15.0rc0
    • 2.15.1
    • 2.16.0
    • 2.16.1
    • 2.16.2
    • 2.17.0
    • 2.17.0rc0
    • 2.17.1
    • 2.17.2
    • 2.18.0
    • 2.18.0rc0
    • 2.19.0
    • 2.19.0rc0
    • 2.2.0
    • 2.2.1
    • 2.2.2
    • 2.20.0
    • 2.20.0rc0
    • 2.20.1
    • 2.20.2
    • 2.20.3
    • 2.20.4
    • 2.21.0
    • 2.21.0rc0
    • 2.21.1
    • 2.21.2
    • 2.21.3
    • 2.3.0
    • 2.3.1
    • 2.3.2
    • 2.4.0
    • 2.4.1
    • 2.4.2
    • 2.5.0
    • 2.6.0
    • 2.7.0
    • 2.7.1
    • 2.8.0
    • 2.8.1
    • 2.9.0
    • 2.9.1
    • 2.9.2
    Affected ranges
    • ECOSYSTEM: < 2.22.0rc0

    Update to 2.22.0rc0

Original sources

Check your server →