p PatchFirst

CVE-2025-11362

CVE-2025-11362

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Versions of the package pdfmake from 0.3.0-beta.1 and before 0.3.0-beta.17 are vulnerable to Allocation of Resources Without Limits or Throttling via repeatedly redirect URL in file embedding. An attacker can cause the application to crash or become unresponsive by providing crafted input that triggers this condition.

CVSS 8.7 · High · EPSS 0.4% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • pdfmake

    Versions
    • ≥ 0.3.0-beta.1, < 0.3.0-beta.17: Affected (semver)

    Update to 0.3.0-beta.17

  • org.webjars.npm:pdfmake

    Versions
    • ≥ 0.3.0-beta.1, < 0.3.0-beta.18: Affected (semver)

    Update to 0.3.0-beta.18

  • pdfmake npm

    Affected ranges
    • SEMVER: ≥ 0.3.0-beta.1, < 0.3.0-beta.17

    Update to 0.3.0-beta.17

Original sources

Check your server →