p PatchFirst

CVE-2025-11971

CVE-2025-11971 · Incorrect Authorization in GitLab

This page contains facts from public vulnerability sources. Check the original advisory before updating.

GitLab has remediated an issue in GitLab EE affecting all versions from 10.6 before 18.3.5, 18.4 before 18.4.3, and 18.5 before 18.5.1 that could have allowed an authenticated attacker to trigger unauthorized pipeline executions by manipulating commits.

CVSS 6.5 · Medium · EPSS 0.2% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • gitlab

    Versions
    • ≥ 10.6, < 18.3.5: Affected (semver)
    • ≥ 18.4, < 18.4.3: Affected (semver)
    • ≥ 18.5, < 18.5.1: Affected (semver)

    Update to 18.3.5; Update to 18.4.3; Update to 18.5.1

  • gitlab Ubuntu:16.04:LTS

    Versions
    • 8.4.3+dfsg-9
    • 8.4.3+dfsg-12
    • 8.5.8+dfsg-5
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →