CVE-2025-12657
CVE-2025-12657 · Malformed KMIP response may result in access violation
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The KMIP response parser built into mongo binaries is overly tolerant of certain malformed packets, and may parse them into invalid objects. Later reads of this object can result in read access violations.
CVSS 5.9 · Medium · EPSS 0.4% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
mongodb server
- Versions
- ≥ 6.0, < 7.0.22: Affected (custom)
- ≥ 8.0, < 8.0.10: Affected (custom)
Update to 7.0.22; Update to 8.0.10
mongodb Ubuntu:Pro:14.04:LTS
- Versions
- 1:2.4.6-0ubuntu5
- 1:2.4.6-0ubuntu6
- 1:2.4.8-1ubuntu1
- 1:2.4.8-2
- 1:2.4.9-1
- 1:2.4.9-1ubuntu1
- 1:2.4.9-1ubuntu2
- 1:2.4.9-1ubuntu2+esm2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
mongodb Ubuntu:Pro:16.04:LTS
- Versions
- 1:2.6.10-0ubuntu1
- 1:2.6.10-0ubuntu1+esm2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
mongodb Ubuntu:Pro:18.04:LTS
- Versions
- 1:3.4.7-1
- 1:3.4.7-1ubuntu1
- 1:3.4.7-1ubuntu2
- 1:3.4.7-1ubuntu4
- 1:3.4.14-3ubuntu1
- 1:3.4.14-3ubuntu2
- 1:3.6.3-0ubuntu1
- 1:3.6.3-0ubuntu1.1
- 1:3.6.3-0ubuntu1.3
- 1:3.6.3-0ubuntu1.4
- 1:3.6.3-0ubuntu1.4+esm1
- 1:3.6.3-0ubuntu1.4+esm2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
mongodb Ubuntu:Pro:20.04:LTS
- Versions
- 1:3.6.9+really3.6.8+90~g8e540c0b6d-0ubuntu2
- 1:3.6.9+really3.6.8+90~g8e540c0b6d-0ubuntu5
- 1:3.6.9+really3.6.8+90~g8e540c0b6d-0ubuntu5.2
- 1:3.6.9+really3.6.8+90~g8e540c0b6d-0ubuntu5.3
- 1:3.6.9+really3.6.8+90~g8e540c0b6d-0ubuntu5.3+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published