p PatchFirst

CVE-2025-12664

CVE-2025-12664 · Improper Validation of Specified Quantity in Input in GitLab

This page contains facts from public vulnerability sources. Check the original advisory before updating.

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 13.0 before 18.8.9, 18.9 before 18.9.5, and 18.10 before 18.10.3 that could have allowed an unauthenticated user to cause denial of service by sending repeated GraphQL queries.

CVSS 7.5 · High · EPSS 0.6% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • gitlab

    Versions
    • ≥ 13.0, < 18.8.9: Affected (semver)
    • ≥ 18.9, < 18.9.5: Affected (semver)
    • ≥ 18.10, < 18.10.3: Affected (semver)

    Update to 18.10.3; Update to 18.8.9; Update to 18.9.5

  • gitlab Ubuntu:16.04:LTS

    Versions
    • 8.4.3+dfsg-9
    • 8.4.3+dfsg-12
    • 8.5.8+dfsg-5
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →