p PatchFirst

CVE-2025-12697

CVE-2025-12697 · Improper Encoding or Escaping of Output in GitLab

This page contains facts from public vulnerability sources. Check the original advisory before updating.

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 15.5 before 18.7.6, 18.8 before 18.8.6, and 18.9 before 18.9.2 that could have allowed an authenticated user with maintainer-role permissions to reveal Datadog API credentials under certain conditions.

CVSS 2.2 · Low · EPSS 0.3% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • gitlab

    Versions
    • ≥ 15.5, < 18.7.6: Affected (semver)
    • ≥ 18.8, < 18.8.6: Affected (semver)
    • ≥ 18.9, < 18.9.2: Affected (semver)

    Update to 18.7.6; Update to 18.8.6; Update to 18.9.2

  • gitlab Ubuntu:16.04:LTS

    Versions
    • 8.4.3+dfsg-9
    • 8.4.3+dfsg-12
    • 8.5.8+dfsg-5
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →