CVE-2025-12735
CVE-2025-12735
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The expr-eval library is a JavaScript expression parser and evaluator designed to safely evaluate mathematical expressions with user-defined variables. However, due to insufficient input validation, an attacker can pass a crafted context object or use MEMBER of the context object into the evaluate() function and trigger arbitrary code execution.
CVSS 9.8 · Critical · EPSS 1.8% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
expr-eval
- Versions
- ≥ 0, ≤ 2.0.2: Affected (semver)
No fix published
expr-eval-fork
- Versions
- ≥ 0, ≤ 3.0.0: Affected (semver)
No fix published
expr-eval npm
- Affected ranges
- SEMVER: ≤ 2.0.2
No fix published
expr-eval-fork npm
- Affected ranges
- SEMVER: < 3.0.1
Update to 3.0.1
Original sources
- https://github.com/silentmatt/expr-eval
- https://github.com/jorenbroekema/expr-eval
- https://www.npmjs.com/package/expr-eval-fork
- https://www.npmjs.com/package/expr-eval
- https://github.com/silentmatt/expr-eval/pull/288
- https://github.com/advisories/GHSA-jc85-fpwf-qm7x
- https://kb.cert.org/vuls/id/263614
- https://github.com/jorenbroekema/expr-eval/blob/460b820ba01c5aca6c5d84a7d4f1fa5d1913c67b/test/security.js
- https://www.kb.cert.org/vuls/id/263614
- https://nvd.nist.gov/vuln/detail/CVE-2025-12735