p PatchFirst

CVE-2025-1278

CVE-2025-1278 · Insufficient Granularity of Access Control in GitLab

This page contains facts from public vulnerability sources. Check the original advisory before updating.

An issue has been discovered in GitLab CE/EE affecting all versions from 12.0 before 17.9.8, 17.10 before 17.10.6, and 17.11 before 17.11.2. Under certain conditions users could bypass IP access restrictions and view sensitive information.

CVSS 5.3 · Medium · EPSS 0.4% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • gitlab

    Versions
    • ≥ 12.0, < 17.9.8: Affected (semver)
    • ≥ 17.10, < 17.10.6: Affected (semver)
    • ≥ 17.11, < 17.11.2: Affected (semver)

    Update to 17.10.6; Update to 17.11.2; Update to 17.9.8

  • gitlab Ubuntu:16.04:LTS

    Versions
    • 8.4.3+dfsg-9
    • 8.4.3+dfsg-12
    • 8.5.8+dfsg-5
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →