CVE-2025-12816
CVE-2025-12816
This page contains facts from public vulnerability sources. Check the original advisory before updating.
An interpretation-conflict (CWE-436) vulnerability in node-forge versions 1.3.1 and earlier enables unauthenticated attackers to craft ASN.1 structures to desynchronize schema validations, yielding a semantic divergence that may bypass downstream cryptographic verifications and security decisions.
CVSS 8.6 · High · EPSS 0.6% · Fix available
- Published
- Updated
Affected products and versions
node-forge
- Versions
- ≥ 0, ≤ 1.3.1: Affected (semver)
No fix published
forge
- Versions
- ≥ 0, ≤ 1.3.1: Affected (semver)
No fix published
node-node-forge Debian:11
- Versions
- 0.10.0~dfsg-3
- 0.10.0~dfsg-3+deb11u1
- 0.10.0~dfsg-4
- 1.2.1~dfsg-1
- 1.2.1~dfsg-2
- 1.3.0~dfsg-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-forge npm
- Affected ranges
- SEMVER: < 1.3.2
Update to 1.3.2
node-node-forge Ubuntu:20.04:LTS
- Versions
- 0.8.5~dfsg-2
- 0.9.1~dfsg-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-node-forge Ubuntu:22.04:LTS
- Versions
- 0.10.0~dfsg-3
- 1.2.1~dfsg-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://www.npmjs.com/package/node-forge
- https://github.com/digitalbazaar/forge/pull/1124
- https://github.com/digitalbazaar/forge
- https://kb.cert.org/vuls/id/521113
- https://github.com/digitalbazaar/forge/security/advisories/GHSA-5gfm-wpxj-wjgq
- https://www.kb.cert.org/vuls/id/521113
- https://nvd.nist.gov/vuln/detail/CVE-2025-12816