CVE-2025-12967
CVE-2025-12967
This page contains facts from public vulnerability sources. Check the original advisory before updating.
An issue in AWS Wrappers for Amazon Aurora PostgreSQL may allow for privilege escalation to rds_superuser role. A low privilege authenticated user can create a crafted function that could be executed with permissions of other Amazon Relational Database Service (RDS) users. We recommend customers upgrade to the following versions: AWS JDBC Wrapper to v2.6.5, AWS Go Wrapper to 2025-10-17, AWS NodeJS Wrapper to v2.0.1, AWS Python Wrapper to v1.4.0 and AWS PGSQL ODBC driver to v1.0.1
CVSS 8.6 · High · EPSS 0.8% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
jdbc wrapper
- Versions
- 2.6.5: Not affected
No fix published
go wrapper
- Versions
- 2025-10-17: Not affected
No fix published
nodejs wrapper
- Versions
- 2.0.1: Not affected
No fix published
python wrapper
- Versions
- 1.4.0: Not affected
No fix published
odbc driver
- Versions
- 1.0.1: Affected
No fix published
aws-advanced-python-wrapper PyPI
- Versions
- 1.0.0
- 1.1.0
- 1.1.1
- 1.2.0
- 1.3.0
- Affected ranges
- ECOSYSTEM: < 1.4.0
Update to 1.4.0
Original sources
- https://aws.amazon.com/security/security-bulletins/AWS-2025-028/
- https://github.com/aws/aws-advanced-jdbc-wrapper/releases/tag/2.6.5
- https://github.com/aws/aws-advanced-go-wrapper/releases/tag/release-2025-10-17
- https://github.com/aws/aws-advanced-python-wrapper/releases/tag/1.4.0
- https://github.com/aws/aws-pgsql-odbc/releases/tag/1.0.1
- https://github.com/aws/aws-advanced-nodejs-wrapper/releases/tag/2.0.1
- https://github.com/aws/aws-advanced-python-wrapper/security/advisories/GHSA-4jvf-wx3f-2x8q
- https://github.com/aws/aws-advanced-jdbc-wrapper/security/advisories/GHSA-7xw4-g7mm-r4hh
- https://github.com/aws/aws-pgsql-odbc/security/advisories/GHSA-q327-fgm8-7mxf
- https://github.com/aws/aws-advanced-go-wrapper/security/advisories/GHSA-7wq2-32h4-9hc9
- https://github.com/aws/aws-advanced-nodejs-wrapper/security/advisories/GHSA-8wj8-cfxr-9374
- https://nvd.nist.gov/vuln/detail/CVE-2025-12967