CVE-2025-12998
CVE-2025-12998 · Broken Authentication in extension “Modules” (modules)
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Improper Authentication vulnerability in TYPO3 Extension "Modules" codingms/modules.This issue affects Extension "Modules": before 4.3.11, from 5.0.0 before 5.7.4, from 6.0.0 before 6.4.2, from 7.0.0 before 7.5.5.
CVSS 8.2 · High · EPSS 0.4% · Fix available
- Published
- Updated
Stack: php
Affected products and versions
extension "modules"
- Versions
- ≥ 0, < 4.3.11: Affected (semver)
- ≥ 5.0.0, < 5.7.4: Affected (semver)
- ≥ 6.0.0, < 6.4.2: Affected (semver)
- ≥ 7.0.0, < 7.5.5: Affected (semver)
Update to 4.3.11; Update to 5.7.4; Update to 6.4.2; Update to 7.5.5
codingms/modules Packagist
- Versions
- 3.0.1
- 3.1.0
- 3.1.1
- 3.1.2
- 3.2.0
- 4.0.0
- 4.0.1
- 4.0.2
- 4.0.3
- 4.0.4
- 4.1.0
- 4.1.1
- 4.1.2
- 4.1.3
- 4.1.4
- 4.1.5
- 4.1.6
- 4.2.0
- 4.2.1
- 4.2.2
- 4.2.3
- 4.2.4
- 4.2.5
- 4.2.6
- 4.2.7
- 4.2.8
- 4.2.9
- 4.3.0
- 4.3.1
- 4.3.10
- 4.3.2
- 4.3.3
- 4.3.4
- 4.3.5
- 4.3.6
- 4.3.7
- 4.3.8
- 4.3.9
- Affected ranges
- ECOSYSTEM: < 4.3.11
Update to 4.3.11
codingms/modules Packagist
- Versions
- 5.0.0
- 5.1.0
- 5.1.1
- 5.1.2
- 5.1.3
- 5.1.4
- 5.2.0
- 5.2.1
- 5.2.2
- 5.3.0
- 5.4.0
- 5.4.1
- 5.5.0
- 5.6.0
- 5.7.0
- 5.7.1
- 5.7.2
- 5.7.3
- Affected ranges
- ECOSYSTEM: ≥ 5.0.0, < 5.7.4
Update to 5.7.4
codingms/modules Packagist
- Versions
- 7.0.0
- 7.0.1
- 7.0.2
- 7.1.0
- 7.1.1
- 7.1.2
- 7.2.0
- 7.2.1
- 7.3.0
- 7.3.1
- 7.3.2
- 7.3.3
- 7.4.0
- 7.4.1
- 7.4.2
- 7.4.3
- 7.4.4
- 7.4.5
- 7.4.6
- 7.5.0
- 7.5.2
- 7.5.3
- 7.5.4
- Affected ranges
- ECOSYSTEM: ≥ 7.0.0, < 7.5.5
Update to 7.5.5
codingms/modules Packagist
- Versions
- 6.0.0
- 6.0.1
- 6.1.0
- 6.1.1
- 6.1.2
- 6.2.0
- 6.2.1
- 6.2.2
- 6.2.3
- 6.2.4
- 6.2.5
- 6.2.6
- 6.2.7
- 6.2.8
- 6.2.9
- 6.3.0
- 6.3.1
- 6.4.0
- 6.4.1
- Affected ranges
- ECOSYSTEM: ≥ 6.0.0, < 6.4.2
Update to 6.4.2