p PatchFirst

CVE-2025-13078

CVE-2025-13078 · Improper Validation of Specified Quantity in Input in GitLab

This page contains facts from public vulnerability sources. Check the original advisory before updating.

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 16.10 before 18.8.7, 18.9 before 18.9.3, and 18.10 before 18.10.1 that could have allowed an authenticated user to cause a denial of service due to excessive resource consumption when processing certain webhook configuration inputs.

CVSS 6.5 · Medium · EPSS 0.4% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • gitlab

    Versions
    • ≥ 16.10, < 18.8.7: Affected (semver)
    • ≥ 18.9, < 18.9.3: Affected (semver)
    • ≥ 18.10, < 18.10.1: Affected (semver)

    Update to 18.10.1; Update to 18.8.7; Update to 18.9.3

  • gitlab Ubuntu:16.04:LTS

    Versions
    • 8.4.3+dfsg-9
    • 8.4.3+dfsg-12
    • 8.5.8+dfsg-5
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →