CVE-2025-13822
CVE-2025-13822 · Authentication bypass in MCPHub
This page contains facts from public vulnerability sources. Check the original advisory before updating.
MCPHub in versions below 0.11.0 is vulnerable to authentication bypass. Some endpoints are not protected by authentication middleware, allowing an unauthenticated attacker to perform actions in the name of other users and using their privileges.
CVSS 5.3 · Medium · EPSS 0.4% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
mcphub
- Versions
- ≥ 0, < 0.11.0: Affected (semver)
Update to 0.11.0
@samanhappy/mcphub npm
- Affected ranges
- SEMVER: < 0.11.0
Update to 0.11.0