CVE-2025-13877
CVE-2025-13877 · nocobase JWT Service jwt-service.ts hard-coded key
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A vulnerability was detected in nocobase up to 1.9.4/2.0.0-alpha.37. The affected element is an unknown function of the file nocobase\packages\core\auth\src\base\jwt-service.ts of the component JWT Service. The manipulation of the argument API_KEY results in use of hard-coded cryptographic key . The attack can be launched remotely. A high complexity level is associated with this attack. The exploitability is described as difficult. The exploit is now public and may be used. The vendor was contacted early about this disclosure but did not respond in any way.
CVSS 6.3 · Medium · EPSS 0.3% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
nocobase
- Versions
- 1.9.0: Affected
- 1.9.1: Affected
- 1.9.2: Affected
- 1.9.3: Affected
- 1.9.4: Affected
- 2.0.0-alpha.0: Affected
- 2.0.0-alpha.1: Affected
- 2.0.0-alpha.2: Affected
- 2.0.0-alpha.3: Affected
- 2.0.0-alpha.4: Affected
- 2.0.0-alpha.5: Affected
- 2.0.0-alpha.6: Affected
- 2.0.0-alpha.7: Affected
- 2.0.0-alpha.8: Affected
- 2.0.0-alpha.9: Affected
- 2.0.0-alpha.10: Affected
- 2.0.0-alpha.11: Affected
- 2.0.0-alpha.12: Affected
- 2.0.0-alpha.13: Affected
- 2.0.0-alpha.14: Affected
- 2.0.0-alpha.15: Affected
- 2.0.0-alpha.16: Affected
- 2.0.0-alpha.17: Affected
- 2.0.0-alpha.18: Affected
- 2.0.0-alpha.19: Affected
- 2.0.0-alpha.20: Affected
- 2.0.0-alpha.21: Affected
- 2.0.0-alpha.22: Affected
- 2.0.0-alpha.23: Affected
- 2.0.0-alpha.24: Affected
- 2.0.0-alpha.25: Affected
- 2.0.0-alpha.26: Affected
- 2.0.0-alpha.27: Affected
- 2.0.0-alpha.28: Affected
- 2.0.0-alpha.29: Affected
- 2.0.0-alpha.30: Affected
- 2.0.0-alpha.31: Affected
- 2.0.0-alpha.32: Affected
- 2.0.0-alpha.33: Affected
- 2.0.0-alpha.34: Affected
- 2.0.0-alpha.35: Affected
- 2.0.0-alpha.36: Affected
- 2.0.0-alpha.37: Affected
No fix published
@nocobase/auth npm
- Affected ranges
- SEMVER: ≥ 1.9.0, < 1.9.23
Update to 1.9.23
@nocobase/auth npm
- Affected ranges
- SEMVER: < 1.9.0-beta.18
Update to 1.9.0-beta.18
@nocobase/auth npm
- Affected ranges
- SEMVER: ≥ 2.0.0-alpha.1, < 2.0.0-alpha.52
Update to 2.0.0-alpha.52