p PatchFirst

CVE-2025-13928

CVE-2025-13928 · Incorrect Authorization in GitLab

This page contains facts from public vulnerability sources. Check the original advisory before updating.

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 17.7 before 18.6.4, 18.7 before 18.7.2, and 18.8 before 18.8.2 that could have allowed an unauthenticated user to cause a denial of service condition by exploiting incorrect authorization validation in API endpoints.

CVSS 7.5 · High · EPSS 0.7% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • gitlab

    Versions
    • ≥ 17.7, < 18.6.4: Affected (semver)
    • ≥ 18.7, < 18.7.2: Affected (semver)
    • ≥ 18.8, < 18.8.2: Affected (semver)

    Update to 18.6.4; Update to 18.7.2; Update to 18.8.2

  • gitlab Ubuntu:16.04:LTS

    Versions
    • 8.4.3+dfsg-9
    • 8.4.3+dfsg-12
    • 8.5.8+dfsg-5
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →