p PatchFirst

CVE-2025-13978

CVE-2025-13978 · Generation of Error Message Containing Sensitive Information in GitLab

This page contains facts from public vulnerability sources. Check the original advisory before updating.

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 17.5 before 18.4.6, 18.5 before 18.5.4, and 18.6 before 18.6.2 that could have allowed an authenticated user to discover the names of private projects they do not have access through API requests.

CVSS 4.3 · Medium · EPSS 0.3% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • gitlab

    Versions
    • ≥ 17.5, < 18.4.6: Affected (semver)
    • ≥ 18.5, < 18.5.4: Affected (semver)
    • ≥ 18.6, < 18.6.2: Affected (semver)

    Update to 18.4.6; Update to 18.5.4; Update to 18.6.2

  • gitlab Ubuntu:16.04:LTS

    Versions
    • 8.4.3+dfsg-9
    • 8.4.3+dfsg-12
    • 8.5.8+dfsg-5
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →