p PatchFirst

CVE-2025-13981

CVE-2025-13981 · AI (Artificial Intelligence) - Moderately critical - Cross-Site Scripting - SA-CONTRIB-2025-119

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Improper Neutralization of Input During Web Page Generation ("Cross-site Scripting") vulnerability in Drupal AI (Artificial Intelligence) allows Cross-Site Scripting (XSS).This issue affects AI (Artificial Intelligence): from 0.0.0 before 1.0.7, from 1.1.0 before 1.1.7, from 1.2.0 before 1.2.4.

CVSS 4.4 · Medium · EPSS 0.1% · Fix available

Published
Updated

Stack: php

Affected products and versions

  • ai (artificial intelligence)

    Versions
    • ≥ 0.0.0, < 1.0.7: Affected (semver)
    • ≥ 1.1.0, < 1.1.7: Affected (semver)
    • ≥ 1.2.0, < 1.2.4: Affected (semver)

    Update to 1.0.7; Update to 1.1.7; Update to 1.2.4

  • drupal/ai Packagist:https://packages.drupal.org/8

    Affected ranges
    • ECOSYSTEM: < 1.0.7
    • ECOSYSTEM: ≥ 1.1.0, < 1.1.7
    • ECOSYSTEM: ≥ 1.2.0, < 1.2.4

    Update to 1.0.7; Update to 1.1.7; Update to 1.2.4

Original sources

Check your server →