CVE-2025-13984
CVE-2025-13984 · Next.js - Critical - Access bypass - SA-CONTRIB-2025-122
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Permissive Cross-domain Security Policy with Untrusted Domains vulnerability in Drupal Next.Js allows Cross-Site Scripting (XSS).This issue affects Next.Js: from 0.0.0 before 1.6.4, from 2.0.0 before 2.0.1.
CVSS 6.1 · Medium · EPSS 0.2% · Fix available
- Published
- Updated
Stack: php
Affected products and versions
next.js
- Versions
- ≥ 0.0.0, < 1.6.4: Affected (semver)
- ≥ 2.0.0, < 2.0.1: Affected (semver)
Update to 1.6.4; Update to 2.0.1
drupal/next Packagist:https://packages.drupal.org/8
- Affected ranges
- ECOSYSTEM: < 1.6.4
- ECOSYSTEM: ≥ 2.0.0, < 2.0.1
Update to 1.6.4; Update to 2.0.1