CVE-2025-14009
CVE-2025-14009 · Zip Slip Vulnerability in nltk/nltk Leading to Remote Code Execution
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A critical vulnerability exists in the NLTK downloader component of nltk/nltk, affecting all versions. The _unzip_iter function in nltk/downloader.py uses zipfile.extractall() without performing path validation or security checks. This allows attackers to craft malicious zip packages that, when downloaded and extracted by NLTK, can execute arbitrary code. The vulnerability arises because NLTK assumes all downloaded packages are trusted and extracts them without validation. If a malicious package contains Python files, such as __init__.py, these files are executed automatically upon import, leading to remote code execution. This issue can result in full system compromise, including file system access, network access, and potential persistence mechanisms.
CVSS 8.8 · High · EPSS 1.0% · Fix available
- Published
- Updated
Affected products and versions
nltk/nltk
- Versions
- ≥ unspecified, ≤ latest: Affected (custom)
No fix published
nltk Debian:12
- Versions
- 3.10.0-1
- 3.10.1-1
- 3.10.3-1
- 3.8-1
- 3.8.1-1
- 3.9.1-1
- 3.9.1-2
- 3.9.2-1
- 3.9.3-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
nltk Debian:13
- Versions
- 3.10.0-1
- 3.10.1-1
- 3.10.3-1
- 3.9.1-2
- 3.9.2-1
- 3.9.3-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
nltk Debian:14
- Versions
- 3.9.1-2
- 3.9.2-1
- Affected ranges
- ECOSYSTEM: < 3.9.3-1
Update to 3.9.3-1
nltk PyPI
- Versions
- 0.8
- 0.9
- 0.9.3
- 0.9.4
- 0.9.5
- 0.9.6
- 0.9.7
- 0.9.8
- 0.9.9
- 2.0.1
- 2.0.1rc1
- 2.0.1rc2-git
- 2.0.1rc3
- 2.0.1rc4
- 2.0.2
- 2.0.3
- 2.0.4
- 2.0.5
- 2.0b4
- 2.0b5
- 2.0b6
- 2.0b7
- 2.0b8
- 2.0b9
- 3.0.0
- 3.0.0b1
- 3.0.0b2
- 3.0.1
- 3.0.2
- 3.0.3
- 3.0.4
- 3.0.5
- 3.1
- 3.2
- 3.2.1
- 3.2.2
- 3.2.3
- 3.2.4
- 3.2.5
- 3.3
- 3.4
- 3.4.1
- 3.4.2
- 3.4.3
- 3.4.4
- 3.4.5
- 3.5
- 3.5b1
- 3.6
- 3.6.1
- 3.6.2
- 3.6.3
- 3.6.4
- 3.6.5
- 3.6.6
- 3.6.7
- 3.7
- 3.8
- 3.8.1
- 3.9
- 3.9.1
- 3.9.2
- 3.9b1
- Affected ranges
- ECOSYSTEM: < 3.9.3
Update to 3.9.3
nltk Ubuntu:Pro:14.04:LTS
- Versions
- 2.0~b9-0ubuntu4
- 2.0~b9-0ubuntu4.1~esm2
- 2.0~b9-0ubuntu4.1~esm4
- Affected ranges
- ECOSYSTEM: < 2.0~b9-0ubuntu4.1~esm5
Update to 2.0~b9-0ubuntu4.1~esm5
nltk Ubuntu:Pro:16.04:LTS
- Versions
- 3.0.4-1
- 3.0.5-1
- 3.1-1
- 3.1-1ubuntu0.1
- 3.1-1ubuntu0.1+esm1
- 3.1-1ubuntu0.1+esm2
- Affected ranges
- ECOSYSTEM: < 3.1-1ubuntu0.1+esm3
Update to 3.1-1ubuntu0.1+esm3
nltk Ubuntu:Pro:18.04:LTS
- Versions
- 3.2.4-1
- 3.2.5-1
- 3.2.5-1ubuntu0.1
- 3.2.5-1ubuntu0.1+esm1
- 3.2.5-1ubuntu0.1+esm2
- Affected ranges
- ECOSYSTEM: < 3.2.5-1ubuntu0.1+esm3
Update to 3.2.5-1ubuntu0.1+esm3
nltk Ubuntu:Pro:20.04:LTS
- Versions
- 3.4.5-1
- 3.4.5-2
- 3.4.5-2ubuntu0.1~esm1
- 3.4.5-2ubuntu0.1~esm2
- Affected ranges
- ECOSYSTEM: < 3.4.5-2ubuntu0.1~esm3
Update to 3.4.5-2ubuntu0.1~esm3
nltk Ubuntu:Pro:22.04:LTS
- Versions
- 3.5-1
- 3.6.5-1
- 3.6.7-1
- 3.7-1
- Affected ranges
- ECOSYSTEM: < 3.7-1ubuntu0.1~esm1
Update to 3.7-1ubuntu0.1~esm1
nltk Ubuntu:Pro:24.04:LTS
- Versions
- 3.8.1-1
- Affected ranges
- ECOSYSTEM: < 3.8.1-1ubuntu0.1~esm1
Update to 3.8.1-1ubuntu0.1~esm1
nltk Ubuntu:25.10
- Versions
- 3.9.1-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
nltk Ubuntu:26.10
- Versions
- 3.9.2-1
- 3.9.3-1
- 3.10.0-1
- 3.10.1-1
- 3.10.3-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
nltk Ubuntu:Pro:26.04:LTS
- Versions
- 3.9.1-2
- 3.9.1-2build1
- 3.9.2-1
- Affected ranges
- ECOSYSTEM: < 3.9.2-1ubuntu0.1~esm1
Update to 3.9.2-1ubuntu0.1~esm1
Original sources
- https://huntr.com/bounties/49ecbc02-054e-4470-b2e0-b267936cc4e4
- https://access.redhat.com/security/cve/CVE-2025-14009
- https://bugzilla.redhat.com/show_bug.cgi?id=2440724
- https://security.access.redhat.com/data/csaf/v2/vex/2025/cve-2025-14009.json
- https://access.redhat.com/errata/RHSA-2026:10184
- https://nvd.nist.gov/vuln/detail/CVE-2025-14009