CVE-2025-14422
CVE-2025-14422 · GIMP PNM File Parsing Integer Overflow Remote Code Execution Vulnerability
This page contains facts from public vulnerability sources. Check the original advisory before updating.
GIMP PNM File Parsing Integer Overflow Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of GIMP. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file. The specific flaw exists within the parsing of PNM files. The issue results from the lack of proper validation of user-supplied data, which can result in an integer overflow before allocating a buffer. An attacker can leverage this vulnerability to execute code in the context of the current process. Was ZDI-CAN-28273.
CVSS 7.8 · High · EPSS 0.6% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
gimp
- Versions
- 3.0.6: Affected
No fix published
gimp Debian:12
- Versions
- 2.10.34-1
- 2.10.34-1+deb12u1
- 2.10.34-1+deb12u2
- 2.10.34-1+deb12u3
- 2.10.34-1+deb12u4
- 2.10.34-1+deb12u5
- Affected ranges
- ECOSYSTEM: < 2.10.34-1+deb12u6
Update to 2.10.34-1+deb12u6
gimp Debian:13
- Versions
- 3.0.4-3
- 3.0.4-3+deb13u1
- 3.0.4-3+deb13u2
- 3.0.4-3+deb13u3
- Affected ranges
- ECOSYSTEM: < 3.0.4-3+deb13u4
Update to 3.0.4-3+deb13u4
gimp Debian:14
- Versions
- 3.0.4-3
- 3.0.4-4
- 3.0.4-5
- 3.0.4-6
- 3.0.4-6.1
- 3.0.4-6.2
- 3.0.6-1
- Affected ranges
- ECOSYSTEM: < 3.2.0~RC2-1
Update to 3.2.0~RC2-1
gimp Ubuntu:Pro:16.04:LTS
- Versions
- 2.8.14-1ubuntu2
- 2.8.14-1.2ubuntu1
- 2.8.16-1ubuntu1
- 2.8.16-1ubuntu1.1
- 2.8.16-1ubuntu1.1+esm1
- Affected ranges
- ECOSYSTEM: < 2.8.16-1ubuntu1.1+esm2
Update to 2.8.16-1ubuntu1.1+esm2
gimp Ubuntu:Pro:18.04:LTS
- Versions
- 2.8.20-1
- 2.8.20-1.1
- 2.8.20-2
- 2.8.22-1
- 2.8.22-1ubuntu0.1~esm1
- Affected ranges
- ECOSYSTEM: < 2.8.22-1ubuntu0.1~esm2
Update to 2.8.22-1ubuntu0.1~esm2
gimp Ubuntu:Pro:20.04:LTS
- Versions
- 2.10.8-2
- 2.10.14-2
- 2.10.14-2build1
- 2.10.14-2ubuntu1
- 2.10.14-3
- 2.10.18-1
- 2.10.18-1ubuntu0.1
- 2.10.18-1ubuntu0.1+esm1
- Affected ranges
- ECOSYSTEM: < 2.10.18-1ubuntu0.1+esm2
Update to 2.10.18-1ubuntu0.1+esm2
gimp Ubuntu:Pro:22.04:LTS
- Versions
- 2.10.24-2
- 2.10.28-1
- 2.10.30-1
- 2.10.30-1build1
- 2.10.30-1ubuntu0.1
- 2.10.30-1ubuntu0.1+esm1
- Affected ranges
- ECOSYSTEM: < 2.10.30-1ubuntu0.1+esm2
Update to 2.10.30-1ubuntu0.1+esm2
gimp Ubuntu:Pro:24.04:LTS
- Versions
- 2.10.34-1
- 2.10.36-1
- 2.10.36-2
- 2.10.36-3build2
- 2.10.36-3build3
- 2.10.36-3ubuntu0.24.04.1
- 2.10.36-3ubuntu0.24.04.1+esm1
- Affected ranges
- ECOSYSTEM: < 2.10.36-3ubuntu0.24.04.1+esm2
Update to 2.10.36-3ubuntu0.24.04.1+esm2
gimp Ubuntu:25.10
- Versions
- 3.0.2-1
- 3.0.2-2
- 3.0.2-3
- 3.0.2-3.1
- 3.0.4-1
- 3.0.4-2
- 3.0.4-3
- 3.0.4-5
- 3.0.4-6
- 3.0.4-6.1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published