CVE-2025-14424
CVE-2025-14424 · GIMP XCF File Parsing Use-After-Free Remote Code Execution Vulnerability
This page contains facts from public vulnerability sources. Check the original advisory before updating.
GIMP XCF File Parsing Use-After-Free Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of GIMP. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file. The specific flaw exists within the parsing of XCF files. The issue results from the lack of validating the existence of an object prior to performing operations on the object. An attacker can leverage this vulnerability to execute code in the context of the current process. Was ZDI-CAN-28376.
CVSS 7.8 · High · EPSS 0.7% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
gimp
- Versions
- 3.0.6: Affected
No fix published
gimp Debian:13
- Versions
- 3.0.4-3
- 3.0.4-3+deb13u1
- 3.0.4-3+deb13u2
- 3.0.4-3+deb13u3
- Affected ranges
- ECOSYSTEM: < 3.0.4-3+deb13u4
Update to 3.0.4-3+deb13u4
gimp Debian:14
- Versions
- 3.0.4-3
- 3.0.4-4
- 3.0.4-5
- 3.0.4-6
- 3.0.4-6.1
- 3.0.4-6.2
- 3.0.6-1
- Affected ranges
- ECOSYSTEM: < 3.2.0~RC2-1
Update to 3.2.0~RC2-1
gimp Ubuntu:25.10
- Versions
- 3.0.2-1
- 3.0.2-2
- 3.0.2-3
- 3.0.2-3.1
- 3.0.4-1
- 3.0.4-2
- 3.0.4-3
- 3.0.4-5
- 3.0.4-6
- 3.0.4-6.1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published