CVE-2025-14560
CVE-2025-14560 · Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab
This page contains facts from public vulnerability sources. Check the original advisory before updating.
GitLab has remediated an issue in GitLab CE/EE affecting all versions from 17.1 before 18.6.6, 18.7 before 18.7.4, and 18.8 before 18.8.4 that, under certain conditions could have allowed an authenticated user to perform unauthorized actions on behalf of another user by injecting malicious content into vulnerability code flow.
CVSS 7.3 · High · EPSS 0.3% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
gitlab
- Versions
- ≥ 17.1, < 18.6.6: Affected (semver)
- ≥ 18.7, < 18.7.4: Affected (semver)
- ≥ 18.8, < 18.8.4: Affected (semver)
Update to 18.6.6; Update to 18.7.4; Update to 18.8.4
gitlab Ubuntu:16.04:LTS
- Versions
- 8.4.3+dfsg-9
- 8.4.3+dfsg-12
- 8.5.8+dfsg-5
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
gitlab-agent Ubuntu:24.04:LTS
- Versions
- 14.1.0-1
- 16.1.3-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
gitlab-agent Ubuntu:25.10
- Versions
- 16.1.3-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
gitlab-agent Ubuntu:26.10
- Versions
- 16.1.3-2build1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
gitlab-agent Ubuntu:26.04:LTS
- Versions
- 16.1.3-2
- 16.1.3-2build1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published