CVE-2025-1467
CVE-2025-1467
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Versions of the package tarteaucitronjs before 1.17.0 are vulnerable to Cross-site Scripting (XSS) via the getElemWidth() and getElemHeight(). This is related to [SNYK-JS-TARTEAUCITRONJS-8366541](https://security.snyk.io/vuln/SNYK-JS-TARTEAUCITRONJS-8366541)
CVSS 5.1 · Medium · EPSS 0.3% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
tarteaucitronjs
- Versions
- ≥ 0, < 1.17.0: Affected (semver)
Update to 1.17.0
tarteaucitronjs npm
- Affected ranges
- SEMVER: < 1.17.0
Update to 1.17.0
Original sources
- https://security.snyk.io/vuln/SNYK-JS-TARTEAUCITRONJS-8731160
- https://github.com/AmauriC/tarteaucitron.js/commit/12490579001d5caa187adcaecb01da570a12076b
- https://github.com/AmauriC/tarteaucitron.js/issues/1184
- https://gist.github.com/Rudloff/d48f525215bd5426cbb076116c4422dd
- https://nvd.nist.gov/vuln/detail/CVE-2025-1467