CVE-2025-1497
CVE-2025-1497 · Remote Code Execution in PlotAI
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A vulnerability, that could result in Remote Code Execution (RCE), has been found in PlotAI. Lack of validation of LLM-generated output allows attacker to execute arbitrary Python code. Vendor commented out vulnerable line, further usage of the software requires uncommenting it and thus accepting the risk. The vendor does not plan to release a patch to fix this vulnerability.
CVSS 9.3 · Critical · EPSS 1.0% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
plotai
- Versions
- ≥ 0, ≤ 0.0.6: Affected (semver)
No fix published
plotai PyPI
- Versions
- 0.0.0
- 0.0.1
- 0.0.2
- 0.0.3
- 0.0.4
- 0.0.5
- 0.0.6
- Affected ranges
- ECOSYSTEM: < 0.0.7
Update to 0.0.7
plotai PyPI
- Versions
- 0.0.0
- 0.0.1
- 0.0.2
- 0.0.3
- 0.0.4
- 0.0.5
- 0.0.6
- v0.0.6
- v0.0.5
- v0.0.4
- v0.0.3
- Affected ranges
- GIT: < bdcfb13484f0b85703a4c1ddfd71cb21840e7fde
- ECOSYSTEM: < 0.0.7
Update to 0.0.7