p PatchFirst

CVE-2025-1540

CVE-2025-1540 · Incorrect Authorization in GitLab

This page contains facts from public vulnerability sources. Check the original advisory before updating.

An issue has been discovered in GitLab CE/EE for Self-Managed and Dedicated instances affecting all versions from 17.5 prior to 17.6.5, 17.7 prior to 17.7.4, and 17.8 prior to 17.8.2. It was possible for a user added as an External to read and clone internal projects under certain circumstances."

CVSS 3.1 · Low · EPSS 0.2% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • gitlab

    Versions
    • ≥ 17.5, < 17.6.5: Affected (semver)
    • ≥ 17.7, < 17.7.4: Affected (semver)
    • ≥ 17.8, < 17.8.2: Affected (semver)

    Update to 17.6.5; Update to 17.7.4; Update to 17.8.2

  • gitlab Ubuntu:16.04:LTS

    Versions
    • 8.4.3+dfsg-9
    • 8.4.3+dfsg-12
    • 8.5.8+dfsg-5
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →