CVE-2025-1752
CVE-2025-1752 · Denial of Service in run-llama/llama_index
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A Denial of Service (DoS) vulnerability has been identified in the KnowledgeBaseWebReader class of the run-llama/llama_index project, affecting version ~ latest(v0.12.15). The vulnerability arises due to inappropriate secure coding measures, specifically the lack of proper implementation of the max_depth parameter in the get_article_urls function. This allows an attacker to exhaust Python's recursion limit through repeated function calls, leading to resource consumption and ultimately crashing the Python process.
CVSS 7.5 · High · EPSS 0.5% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
run-llama/llama_index
- Versions
- ≥ unspecified, < 0.3.6: Affected (custom)
Update to 0.3.6
llama-index PyPI
- Versions
- 0.12.15
- 0.12.16
- 0.12.17
- 0.12.18
- 0.12.19
- 0.12.20
- Affected ranges
- ECOSYSTEM: ≥ 0.12.15, < 0.12.21
Update to 0.12.21