p PatchFirst

CVE-2025-21610

CVE-2025-21610 · Trix allows Cross-site Scripting via `javascript:` url in a link

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Trix is a what-you-see-is-what-you-get rich text editor for everyday writing. Versions prior to 2.1.12 are vulnerable to cross-site scripting when pasting malicious code in the link field. An attacker could trick the user to copy&paste a malicious `javascript:` URL as a link that would execute arbitrary JavaScript code within the context of the user's session, potentially leading to unauthorized actions being performed or sensitive information being disclosed. Users should upgrade to Trix editor version 2.1.12 or later to receive a patch. In addition to upgrading, affected users can disallow browsers that don't support a Content Security Policy (CSP) as a workaround for this and other cross-site scripting vulnerabilities. Set CSP policies such as script-src 'self' to ensure that only scripts hosted on the same origin are executed, and explicitly prohibit inline scripts using script-src-elem.

CVSS 5.3 · Medium · EPSS 0.4% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • trix

    Versions
    • < 2.1.12: Affected

    No fix published

  • trix npm

    Affected ranges
    • SEMVER: < 2.1.12

    Update to 2.1.12

Original sources

Check your server →