CVE-2025-2174
CVE-2025-2174 · libzvbi conv.c vbi_strndup_iconv_ucs2 integer overflow
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A vulnerability was found in libzvbi up to 0.2.43. It has been declared as problematic. Affected by this vulnerability is the function vbi_strndup_iconv_ucs2 of the file src/conv.c. The manipulation of the argument src_length leads to integer overflow. The attack can be launched remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 0.2.44 is able to address this issue. The patch is named ca1672134b3e2962cd392212c73f44f8f4cb489f. It is recommended to upgrade the affected component. The code maintainer was informed beforehand about the issues. She reacted very fast and highly professional.
CVSS 6.9 · Medium · EPSS 0.8% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
libzvbi
- Versions
- 0.2.0: Affected
- 0.2.1: Affected
- 0.2.2: Affected
- 0.2.3: Affected
- 0.2.4: Affected
- 0.2.5: Affected
- 0.2.6: Affected
- 0.2.7: Affected
- 0.2.8: Affected
- 0.2.9: Affected
- 0.2.10: Affected
- 0.2.11: Affected
- 0.2.12: Affected
- 0.2.13: Affected
- 0.2.14: Affected
- 0.2.15: Affected
- 0.2.16: Affected
- 0.2.17: Affected
- 0.2.18: Affected
- 0.2.19: Affected
- 0.2.20: Affected
- 0.2.21: Affected
- 0.2.22: Affected
- 0.2.23: Affected
- 0.2.24: Affected
- 0.2.25: Affected
- 0.2.26: Affected
- 0.2.27: Affected
- 0.2.28: Affected
- 0.2.29: Affected
- 0.2.30: Affected
- 0.2.31: Affected
- 0.2.32: Affected
- 0.2.33: Affected
- 0.2.34: Affected
- 0.2.35: Affected
- 0.2.36: Affected
- 0.2.37: Affected
- 0.2.38: Affected
- 0.2.39: Affected
- 0.2.40: Affected
- 0.2.41: Affected
- 0.2.42: Affected
- 0.2.43: Affected
No fix published
zvbi Debian:12
- Versions
- 0.2.41-1
- Affected ranges
- ECOSYSTEM: < 0.2.41-1+deb12u1
Update to 0.2.41-1+deb12u1
zvbi Debian:13
- Affected ranges
- ECOSYSTEM: < 0.2.44-1
Update to 0.2.44-1
zvbi Debian:14
- Affected ranges
- ECOSYSTEM: < 0.2.44-1
Update to 0.2.44-1
zvbi Ubuntu:14.04:LTS
- Versions
- 0.2.33-7
- 0.2.35-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
zvbi Ubuntu:Pro:16.04:LTS
- Versions
- 0.2.35-9
- 0.2.35-10
- Affected ranges
- ECOSYSTEM: < 0.2.35-10ubuntu0.1~esm1
Update to 0.2.35-10ubuntu0.1~esm1
zvbi Ubuntu:Pro:18.04:LTS
- Versions
- 0.2.35-13
- Affected ranges
- ECOSYSTEM: < 0.2.35-13ubuntu0.1~esm1
Update to 0.2.35-13ubuntu0.1~esm1
zvbi Ubuntu:Pro:20.04:LTS
- Versions
- 0.2.35-16
- 0.2.35-17
- Affected ranges
- ECOSYSTEM: < 0.2.35-17ubuntu0.1~esm1
Update to 0.2.35-17ubuntu0.1~esm1
zvbi Ubuntu:Pro:22.04:LTS
- Versions
- 0.2.35-18
- 0.2.35-19
- Affected ranges
- ECOSYSTEM: < 0.2.35-19ubuntu0.1~esm1
Update to 0.2.35-19ubuntu0.1~esm1
zvbi Ubuntu:Pro:24.04:LTS
- Versions
- 0.2.41-2
- 0.2.42-1
- 0.2.42-1.1
- 0.2.42-1.2
- 0.2.42-2
- Affected ranges
- ECOSYSTEM: < 0.2.42-2ubuntu0.24.04.1~esm1
Update to 0.2.42-2ubuntu0.24.04.1~esm1
Original sources
- https://vuldb.com/?id.299203
- https://vuldb.com/?ctiid.299203
- https://vuldb.com/?submit.512800
- https://github.com/zapping-vbi/zvbi/security/advisories/GHSA-g7cg-7gw9-v8cf
- https://github.com/zapping-vbi/zvbi/commit/ca1672134b3e2962cd392212c73f44f8f4cb489f
- https://github.com/zapping-vbi/zvbi/releases/tag/v0.2.44
- https://nvd.nist.gov/vuln/detail/CVE-2025-2174