CVE-2025-23165
CVE-2025-23165
This page contains facts from public vulnerability sources. Check the original advisory before updating.
In Node.js, the `ReadFileUtf8` internal binding leaks memory due to a corrupted pointer in `uv_fs_s.file`: a UTF-16 path buffer is allocated but subsequently overwritten when the file descriptor is set. This results in an unrecoverable memory leak on every call. Repeated use can cause unbounded memory growth, leading to a denial of service. Impact: * This vulnerability affects APIs relying on `ReadFileUtf8` on Node.js release lines: v20 and v22.
CVSS 3.7 · Low · EPSS 0.6% · Fix available
- Published
- Updated
Affected products and versions
node.js
- Versions
- ≥ 4.0, < 4.*: Affected (semver)
- ≥ 5.0, < 5.*: Affected (semver)
- ≥ 6.0, < 6.*: Affected (semver)
- ≥ 7.0, < 7.*: Affected (semver)
- ≥ 8.0, < 8.*: Affected (semver)
- ≥ 9.0, < 9.*: Affected (semver)
- ≥ 10.0, < 10.*: Affected (semver)
- ≥ 11.0, < 11.*: Affected (semver)
- ≥ 12.0, < 12.*: Affected (semver)
- ≥ 13.0, < 13.*: Affected (semver)
- ≥ 14.0, < 14.*: Affected (semver)
- ≥ 15.0, < 15.*: Affected (semver)
- ≥ 16.0, < 16.*: Affected (semver)
- ≥ 17.0, < 17.*: Affected (semver)
- ≥ 18.0, < 18.*: Affected (semver)
- ≥ 19.0, < 19.*: Affected (semver)
- ≥ 20.0, ≤ 20.19.1: Affected (semver)
- ≥ 22.0, ≤ 22.15.0: Affected (semver)
- ≥ 21.0, < 21.*: Affected (semver)
No fix published
nodejs Debian:13
- Affected ranges
- ECOSYSTEM: < 20.19.2+dfsg-1
Update to 20.19.2+dfsg-1
nodejs Debian:14
- Affected ranges
- ECOSYSTEM: < 20.19.2+dfsg-1
Update to 20.19.2+dfsg-1