p PatchFirst

CVE-2025-23200

CVE-2025-23200 · Stored XSS-LibreNMS-Misc Section in librenms

This page contains facts from public vulnerability sources. Check the original advisory before updating.

librenms is a community-based GPL-licensed network monitoring system. Affected versions are subject to a stored XSS on the parameter: `ajax_form.php` -> param: state. Librenms versions up to 24.10.1 allow remote attackers to inject malicious scripts. When a user views or interacts with the page displaying the data, the malicious script executes immediately, leading to potential unauthorized actions or data exposure. This issue has been addressed in release version 24.11.0. Users are advised to upgrade. There are no known workarounds for this vulnerability.

CVSS 4.6 · Medium · EPSS 31.6% · Fix available

Published
Updated

Stack: php

Affected products and versions

  • librenms

    Versions
    • < 24.11.0: Affected

    No fix published

  • librenms/librenms Packagist

    Versions
    • 23.10.0
    • 23.11.0
    • 23.9.0
    • 23.9.1
    • 24.1.0
    • 24.10.0
    • 24.10.1
    • 24.2.0
    • 24.3.0
    • 24.4.0
    • 24.4.1
    • 24.5.0
    • 24.6.0
    • 24.7.0
    • 24.8.0
    • 24.8.1
    • 24.9.0
    • 24.9.1
    Affected ranges
    • ECOSYSTEM: ≥ 23.9.0, < 24.11.0

    Update to 24.11.0

Original sources

Check your server →