CVE-2025-23204
CVE-2025-23204 · GraphQl securityAfterResolver not called
This page contains facts from public vulnerability sources. Check the original advisory before updating.
API Platform Core is a system to create hypermedia-driven REST and GraphQL APIs. Starting in version 3.3.8, a security check that gets called after GraphQl resolvers is always replaced by another one as there's no break in a clause. As this falls back to `security`, the impact is there only when there's only a security after resolver and none inside security. Version 3.3.15 contains a patch for the issue.
CVSS 4.4 · Medium · EPSS 0.3% · Fix available
- Published
- Updated
Stack: php
Affected products and versions
core
- Versions
- >= 3.3.8, < 3.3.15: Affected
No fix published
api-platform/core Packagist
- Versions
- v3.3.10
- v3.3.11
- v3.3.12
- v3.3.13
- v3.3.14
- v3.3.8
- v3.3.9
- Affected ranges
- ECOSYSTEM: ≥ 3.3.8, < 3.3.15
Update to 3.3.15
Original sources
- https://github.com/api-platform/core/security/advisories/GHSA-7mxx-3cgm-xxv3
- https://github.com/api-platform/core/pull/6444
- https://github.com/api-platform/core/pull/6444/files#diff-09e3c2cfe12a2ce65bd6c983c7ca6bfcf783f852b8d0554bb938e8ebf5e5fa65R56
- https://github.com/api-platform/core/commit/dc4fc84ba93e22b4f44a37e90a93c6d079c1c620
- https://github.com/soyuka/core/blob/7e2e8f9ff322ac5f6eb5f65baf432bffdca0fd51/src/Symfony/Security/State/AccessCheckerProvider.php#L49-L57
- https://nvd.nist.gov/vuln/detail/CVE-2025-23204