CVE-2025-24017
CVE-2025-24017 · YesWiki Vulnerable to Unauthenticated DOM Based XSS
This page contains facts from public vulnerability sources. Check the original advisory before updating.
YesWiki is a wiki system written in PHP. Versions up to and including 4.4.5 are vulnerable to any end-user crafting a DOM based XSS on all of YesWiki's pages which is triggered when a user clicks on a malicious link. The vulnerability makes use of the search by tag feature. When a tag doesn't exist, the tag is reflected on the page and isn't properly sanitized on the server side which allows a malicious user to generate a link that will trigger an XSS on the client's side when clicked. This vulnerability allows any user to generate a malicious link that will trigger an account takeover when clicked, therefore allowing a user to steal other accounts, modify pages, comments, permissions, extract user data (emails), thus impacting the integrity, availability and confidentiality of a YesWiki instance. Version 4.5.0 contains a patch for the issue.
CVSS 7.6 · High · EPSS 0.4% · Fix available
- Published
- Updated
Stack: php
Affected products and versions
yeswiki
- Versions
- < 4.5.0: Affected
No fix published
yeswiki/yeswiki Packagist
- Versions
- 4.2.3
- v4.1.0
- v4.1.1
- v4.1.2
- v4.1.3
- v4.1.4
- v4.1.5
- v4.2.0
- v4.2.1
- v4.2.2
- v4.2.4
- v4.3
- v4.3.1
- v4.4.0
- v4.4.1
- v4.4.2
- v4.4.3
- v4.4.4
- v4.4.5
- Affected ranges
- ECOSYSTEM: < 4.5.0
Update to 4.5.0