CVE-2025-24018
CVE-2025-24018 · YesWiki Vulnerable to Authenticated Stored XSS
This page contains facts from public vulnerability sources. Check the original advisory before updating.
YesWiki is a wiki system written in PHP. In versions up to and including 4.4.5, it is possible for an authenticated user with rights to edit/create a page or comment to trigger a stored XSS which will be reflected on any page where the resource is loaded. The vulnerability makes use of the content edition feature and more specifically of the `{{attach}}` component allowing users to attach files/medias to a page. When a file is attached using the `{{attach}}` component, if the resource contained in the `file` attribute doesn't exist, then the server will generate a file upload button containing the filename. This vulnerability allows any malicious authenticated user that has the right to create a comment or edit a page to be able to steal accounts and therefore modify pages, comments, permissions, extract user data (emails), thus impacting the integrity, availability and confidentiality of a YesWiki instance. Version 4.5.0 contains a patch for the issue.
CVSS 7.6 · High · EPSS 0.4% · Fix available
- Published
- Updated
Stack: php
Affected products and versions
yeswiki
- Versions
- < 4.5.0: Affected
No fix published
yeswiki/yeswiki Packagist
- Versions
- 4.2.3
- v4.1.0
- v4.1.1
- v4.1.2
- v4.1.3
- v4.1.4
- v4.1.5
- v4.2.0
- v4.2.1
- v4.2.2
- v4.2.4
- v4.3
- v4.3.1
- v4.4.0
- v4.4.1
- v4.4.2
- v4.4.3
- v4.4.4
- v4.4.5
- Affected ranges
- ECOSYSTEM: < 4.5.0
Update to 4.5.0