CVE-2025-24027
CVE-2025-24027 · ps_contactinfo has potential XSS due to usage of the nofilter tag in template
This page contains facts from public vulnerability sources. Check the original advisory before updating.
ps_contactinfo, a PrestaShop module for displaying store contact information, has a cross-site scripting (XSS) vulnerability in versions up to and including 3.3.2. This can not be exploited in a fresh install of PrestaShop, only shops made vulnerable by third party modules are concerned. For example, if the shop has a third party module vulnerable to SQL injections, then ps_contactinfo might execute a stored cross-site scripting in formatting objects. Commit d60f9a5634b4fc2d3a8831fb08fe2e1f23cbfa39 keeps formatted addresses from displaying a XSS stored in the database, and the fix is expected to be available in version 3.3.3. No workarounds are available aside from applying the fix and keeping all modules maintained and update.
CVSS 6.2 · Medium · EPSS 0.4% · Fix available
- Published
- Updated
Stack: php
Affected products and versions
ps_contactinfo
- Versions
- <= 3.3.2: Affected
No fix published
prestashop/ps_contactinfo Packagist
- Versions
- v2.0.1
- v3.0.0
- v3.1.0
- v3.2.0
- v3.3.0
- v3.3.1
- v3.3.2
- Affected ranges
- ECOSYSTEM: < 3.3.3
Update to 3.3.3