p PatchFirst

CVE-2025-2408

CVE-2025-2408 · Insufficient Granularity of Access Control in GitLab

This page contains facts from public vulnerability sources. Check the original advisory before updating.

An issue has been discovered in GitLab CE/EE affecting all versions from 13.12 before 17.8.7, 17.9 before 17.9.6, and 17.10 before 17.10.4. Under certain conditions users could bypass IP access restrictions and view sensitive information.

CVSS 5.3 · Medium · EPSS 0.3% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • gitlab

    Versions
    • ≥ 13.12, < 17.8.7: Affected (semver)
    • ≥ 17.9, < 17.9.6: Affected (semver)
    • ≥ 17.10, < 17.10.4: Affected (semver)

    Update to 17.10.4; Update to 17.8.7; Update to 17.9.6

  • gitlab Ubuntu:16.04:LTS

    Versions
    • 8.4.3+dfsg-9
    • 8.4.3+dfsg-12
    • 8.5.8+dfsg-5
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →