p PatchFirst

CVE-2025-2443

CVE-2025-2443 · Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab

This page contains facts from public vulnerability sources. Check the original advisory before updating.

An issue has been discovered in GitLab EE that allows for cross-site-scripting attack and content security policy bypass in a user's browser under specific conditions, affecting all versions from 16.6 before 17.9.7, 17.10 before 17.10.5, and 17.11 before 17.11.1.

CVSS 8.7 · High · EPSS 0.4% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • gitlab

    Versions
    • ≥ 16.6, < 17.9.7: Affected (semver)
    • ≥ 17.10, < 17.10.5: Affected (semver)
    • ≥ 17.11, < 17.11.1: Affected (semver)

    Update to 17.10.5; Update to 17.11.1; Update to 17.9.7

  • gitlab Ubuntu:16.04:LTS

    Versions
    • 8.4.3+dfsg-9
    • 8.4.3+dfsg-12
    • 8.5.8+dfsg-5
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →