CVE-2025-24876
CVE-2025-24876 · Authentication bypass via authorization code injection in SAP Approuter
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The SAP Approuter Node.js package version v16.7.1 and before is vulnerable to Authentication bypass. When trading an authorization code an attacker can steal the session of the victim by injecting malicious payload causing High impact on confidentiality and integrity of the application
CVSS 8.1 · High · EPSS 0.5% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
sap approuter node.js package
- Versions
- 2.6.1 to 16.7.1: Affected
No fix published
@sap/approuter npm
- Affected ranges
- SEMVER: ≥ 2.6.1, < 16.7.2
Update to 16.7.2