p PatchFirst

CVE-2025-2498

CVE-2025-2498 · Insufficient Granularity of Access Control in GitLab

This page contains facts from public vulnerability sources. Check the original advisory before updating.

An improper access control in Gitlab EE affecting all versions from 12.0 prior to 18.0.6, 18.1 prior to 18.1.4, and 18.2 prior to 18.2.2 that under certain conditions could have allowed users to view assigned issues from restricted groups by bypassing IP restrictions.

CVSS 3.1 · Low · EPSS 0.3% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • gitlab

    Versions
    • ≥ 12.0, < 18.0.6: Affected (semver)
    • ≥ 18.1, < 18.1.4: Affected (semver)
    • ≥ 18.2, < 18.2.2: Affected (semver)

    Update to 18.0.6; Update to 18.1.4; Update to 18.2.2

  • gitlab Ubuntu:16.04:LTS

    Versions
    • 8.4.3+dfsg-9
    • 8.4.3+dfsg-12
    • 8.5.8+dfsg-5
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →