p PatchFirst

CVE-2025-25186

CVE-2025-25186 · Net::IMAP vulnerable to possible DoS by memory exhaustion

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Net::IMAP implements Internet Message Access Protocol (IMAP) client functionality in Ruby. Starting in version 0.3.2 and prior to versions 0.3.8, 0.4.19, and 0.5.6, there is a possibility for denial of service by memory exhaustion in `net-imap`'s response parser. At any time while the client is connected, a malicious server can send can send highly compressed `uid-set` data which is automatically read by the client's receiver thread. The response parser uses `Range#to_a` to convert the `uid-set` data into arrays of integers, with no limitation on the expanded size of the ranges. Versions 0.3.8, 0.4.19, 0.5.6, and higher fix this issue. Additional details for proper configuration of fixed versions and backward compatibility are available in the GitHub Security Advisory.

CVSS 6.5 · Medium · EPSS 0.6% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • net-imap

    Versions
    • >= 0.3.2, < 0.3.8: Affected
    • >= 0.4.0, < 0.4.19: Affected
    • >= 0.5.0, < 0.5.6: Affected

    No fix published

  • ruby3.1 Debian:12

    Versions
    • 3.1.2-7
    • 3.1.2-7+deb12u1
    • 3.1.2-7+hurd.1
    • 3.1.2-8
    • 3.1.2-8.1~exp1
    • 3.1.2-8.3
    • 3.1.2-8.4
    • 3.1.2-8.5
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • ruby3.3 Debian:13

    Affected ranges
    • ECOSYSTEM: < 3.3.8-1

    Update to 3.3.8-1

  • ruby3.3 Debian:14

    Affected ranges
    • ECOSYSTEM: < 3.3.8-1

    Update to 3.3.8-1

  • ruby3.2 Ubuntu:24.04:LTS

    Versions
    • 3.2.3-1
    • 3.2.3-1build2
    • 3.2.3-1build3
    • 3.2.3-1ubuntu0.24.04.1
    • 3.2.3-1ubuntu0.24.04.3
    Affected ranges
    • ECOSYSTEM: < 3.2.3-1ubuntu0.24.04.5

    Update to 3.2.3-1ubuntu0.24.04.5

Original sources

Check your server →