CVE-2025-25304
CVE-2025-25304 · Vega allows Cross-site Scripting via the vlSelectionTuples function
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Vega is a visualization grammar, a declarative format for creating, saving, and sharing interactive visualization designs. Prior to version 5.26.0 of vega and 5.4.2 of vega-selections, the `vlSelectionTuples` function can be used to call JavaScript functions, leading to cross-site scripting.`vlSelectionTuples` calls multiple functions that can be controlled by an attacker, including one call with an attacker-controlled argument. This can be used to call `Function()` with arbitrary JavaScript and the resulting function can be called with `vlSelectionTuples` or using a type coercion to call `toString` or `valueOf`. Version 5.26.0 of vega and 5.4.2 of vega-selections fix this issue.
CVSS 6.9 · Medium · EPSS 0.7% · Fix available
- Published
- Updated
Affected products and versions
vega
- Versions
- < 5.26.0: Affected
No fix published
vega.js Debian:12
- Versions
- 5.22.1+ds+~3.1.0-4
- 5.25.0+ds+~cs5.3.0-1
- 5.25.0+ds+~cs5.3.0-2
- 5.25.0+ds+~cs5.3.0-3
- 5.25.0+ds+~cs5.3.0-4
- 5.25.0+ds+~cs5.3.0-5
- 5.28.0+ds+~cs5.3.0-1
- 5.28.0+ds+~cs5.3.0-2
- 5.28.0+ds+~cs5.3.0-3
- 5.33.1+ds+~cs5.3.0-1
- 5.33.1+ds+~cs5.3.0-2
- 5.33.1+ds+~cs5.3.0-3
- 5.33.1+ds+~cs5.3.0-4
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
vega.js Debian:13
- Affected ranges
- ECOSYSTEM: < 5.28.0+ds+~cs5.3.0-1
Update to 5.28.0+ds+~cs5.3.0-1
vega.js Debian:14
- Affected ranges
- ECOSYSTEM: < 5.28.0+ds+~cs5.3.0-1
Update to 5.28.0+ds+~cs5.3.0-1
vega npm
- Affected ranges
- SEMVER: < 5.26.0
Update to 5.26.0
vega-selections npm
- Affected ranges
- SEMVER: < 5.4.2
Update to 5.4.2
vega.js Ubuntu:24.04:LTS
- Versions
- 5.25.0+ds+~cs5.3.0-2
- 5.25.0+ds+~cs5.3.0-5
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
vega.js Ubuntu:25.10
- Versions
- 5.28.0+ds+~cs5.3.0-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
vega.js Ubuntu:26.10
- Versions
- 5.28.0+ds+~cs5.3.0-2
- 5.33.1+ds+~cs5.3.0-4
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
vega.js Ubuntu:26.04:LTS
- Versions
- 5.28.0+ds+~cs5.3.0-1
- 5.28.0+ds+~cs5.3.0-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://github.com/vega/vega/security/advisories/GHSA-mp7w-mhcv-673j
- https://github.com/vega/vega/commit/9fb9ea07e27984394e463d286eb73944fa61411e
- https://github.com/vega/vega/blob/b45cf431cd6c0d0c0e1567f087f9b3b55bc236fa/packages/vega-selections/src/selectionTuples.js#L14
- https://nvd.nist.gov/vuln/detail/CVE-2025-25304