CVE-2025-2545
CVE-2025-2545 · Deprecated 3DES cryptographic algorithm used by Request Tracker in emails encrypted with S/MIME
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Vulnerability in Best Practical Solutions, LLC's Request Tracker prior to v5.0.8, where the Triple DES (3DES) cryptographic algorithm is used to protect emails sent with S/MIME encryption. Triple DES is considered obsolete and insecure due to its susceptibility to birthday attacks, which could compromise the confidentiality of encrypted messages.
CVSS 2.3 · Low · EPSS 0.2% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
request tracker
- Versions
- ≥ 0, < 5.0.8: Affected (custom)
Update to 5.0.8
request-tracker4 Debian:12
- Versions
- 4.4.6+dfsg-1.1
- 4.4.6+dfsg-1.1+deb12u1
- Affected ranges
- ECOSYSTEM: < 4.4.6+dfsg-1.1+deb12u2
Update to 4.4.6+dfsg-1.1+deb12u2
request-tracker5 Debian:12
- Versions
- 5.0.3+dfsg-2
- 5.0.3+dfsg-3~deb12u1
- 5.0.3+dfsg-3~deb12u2
- Affected ranges
- ECOSYSTEM: < 5.0.3+dfsg-3~deb12u3
Update to 5.0.3+dfsg-3~deb12u3
request-tracker5 Debian:13
- Affected ranges
- ECOSYSTEM: < 5.0.7+dfsg-3
Update to 5.0.7+dfsg-3
request-tracker5 Debian:14
- Affected ranges
- ECOSYSTEM: < 5.0.7+dfsg-3
Update to 5.0.7+dfsg-3
request-tracker4 Ubuntu:16.04:LTS
- Versions
- 4.2.11-2
- 4.2.12-3
- 4.2.12-4
- 4.2.12-5
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
request-tracker4 Ubuntu:Pro:18.04:LTS
- Versions
- 4.4.1-5
- 4.4.2-1
- 4.4.2-2
- 4.4.2-2ubuntu0.1~esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
request-tracker4 Ubuntu:20.04:LTS
- Versions
- 4.4.3-2
- 4.4.3-2+deb10u3build0.20.04.1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
request-tracker4 Ubuntu:22.04:LTS
- Versions
- 4.4.4+dfsg-2ubuntu1
- 4.4.4+dfsg-2ubuntu1.22.04.1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
request-tracker5 Ubuntu:Pro:22.04:LTS
- Versions
- 5.0.1+dfsg-1ubuntu1
- Affected ranges
- ECOSYSTEM: < 5.0.1+dfsg-1ubuntu1+esm1
Update to 5.0.1+dfsg-1ubuntu1+esm1
request-tracker4 Ubuntu:24.04:LTS
- Versions
- 4.4.4+dfsg-2ubuntu1
- 4.4.4+dfsg-2ubuntu2
- 4.4.7+dfsg-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
request-tracker5 Ubuntu:Pro:24.04:LTS
- Versions
- 5.0.1+dfsg-1ubuntu1
- 5.0.5+dfsg-2
- Affected ranges
- ECOSYSTEM: < 5.0.5+dfsg-2ubuntu0.1~esm1
Update to 5.0.5+dfsg-2ubuntu0.1~esm1
request-tracker4 Ubuntu:25.10
- Versions
- 4.4.7+dfsg-4syncable1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
request-tracker4 Ubuntu:26.04:LTS
- Versions
- 4.4.7+dfsg-4syncable1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://www.incibe.es/en/incibe-cert/notices/aviso/cryptographic-algorithm-not-recommended-request-tracker-best-practical
- https://docs.bestpractical.com/release-notes/rt/4.4.8
- https://docs.bestpractical.com/release-notes/rt/5.0.8
- https://lists.debian.org/debian-lts-announce/2025/05/msg00009.html
- https://nvd.nist.gov/vuln/detail/CVE-2025-2545