p PatchFirst

CVE-2025-2615

CVE-2025-2615 · Insertion of Sensitive Information Into Sent Data in GitLab

This page contains facts from public vulnerability sources. Check the original advisory before updating.

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 16.7 before 18.3.6, 18.4 before 18.4.4, and 18.5 before 18.5.2, that could have allowed a blocked user to access sensitive information by establishing GraphQL subscriptions through WebSocket connections.

CVSS 4.3 · Medium · EPSS 0.4% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • gitlab

    Versions
    • ≥ 16.7, < 18.3.6: Affected (semver)
    • ≥ 18.4, < 18.4.4: Affected (semver)
    • ≥ 18.5, < 18.5.2: Affected (semver)

    Update to 18.3.6; Update to 18.4.4; Update to 18.5.2

  • gitlab Ubuntu:16.04:LTS

    Versions
    • 8.4.3+dfsg-9
    • 8.4.3+dfsg-12
    • 8.5.8+dfsg-5
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →