CVE-2025-26530
CVE-2025-26530 · Reflected XSS via question bank filter
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The question bank filter required additional sanitizing to prevent a reflected XSS risk.
CVSS 8.3 · High · EPSS 0.4% · Fix available
- Published
- Updated
Affected products and versions
moodle
- Versions
- ≥ 4.5.0, < 4.5.2: Affected (semver)
- ≥ 4.4.0, < 4.4.6: Affected (semver)
- ≥ 4.3.0, < 4.3.10: Affected (semver)
- ≥ 0, < 4.2.*: Unknown (semver)
Update to 4.3.10; Update to 4.4.6; Update to 4.5.2
moodle/moodle Packagist
- Versions
- v4.5.0
- v4.5.0-beta
- v4.5.0-rc1
- v4.5.0-rc2
- v4.5.1
- Affected ranges
- ECOSYSTEM: ≥ 4.5.0-beta, < 4.5.2
Update to 4.5.2
moodle/moodle Packagist
- Versions
- v4.4.0
- v4.4.0-beta
- v4.4.0-rc1
- v4.4.0-rc2
- v4.4.1
- v4.4.2
- v4.4.3
- v4.4.4
- v4.4.5
- Affected ranges
- ECOSYSTEM: ≥ 4.4.0-beta, < 4.4.6
Update to 4.4.6
moodle/moodle Packagist
- Versions
- v4.3.0
- v4.3.0-beta
- v4.3.0-rc1
- v4.3.0-rc2
- v4.3.1
- v4.3.2
- v4.3.3
- v4.3.4
- v4.3.5
- v4.3.6
- v4.3.7
- v4.3.8
- v4.3.9
- Affected ranges
- ECOSYSTEM: ≥ 4.3.0-beta, < 4.3.10
Update to 4.3.10
moodle Ubuntu:Pro:16.04:LTS
- Versions
- 2.7.9+dfsg-1
- 2.7.10+dfsg-1
- 2.7.11+dfsg-1
- 2.7.11+dfsg-2
- 2.7.12+dfsg-1
- 3.0.3+dfsg-0ubuntu1
- 3.0.3+dfsg-0ubuntu1+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
moodle Ubuntu:Pro:18.04:LTS
- Versions
- 3.0.3+dfsg-0ubuntu1
- 3.0.3+dfsg-0ubuntu1+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published