CVE-2025-27400
CVE-2025-27400 · Magento vulnerable to stored XSS in theme config fields
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Magento Long Term Support (LTS) is an unofficial, community-driven project provides an alternative to the Magento Community Edition e-commerce platform with a high level of backward compatibility. Versions prior to 20.12.3 and 20.13.0 contain a vulnerability that allows script execution in the admin panel which could lead to cross-site scripting against authenticated admin users. The attack requires an admin user with configuration access, so in practicality it is not very likely to be useful given that a user with this level of access is probably already a full admin. Versions 20.12.3 and 20.13.0 contain a patch for the issue.
CVSS 2.9 · Low · EPSS 0.3% · Fix available
- Published
- Updated
Stack: php
Affected products and versions
magento-lts
- Versions
- < 20.12.3: Affected
No fix published
openmage/magento-lts Packagist
- Versions
- 1.9.1.1
- 1.9.2.0
- 1.9.2.1
- 1.9.2.2
- 1.9.2.3
- 1.9.2.4
- 1.9.3.0
- 1.9.3.1
- v19.4.0
- v19.4.1
- v19.4.10
- v19.4.11
- v19.4.12
- v19.4.13
- v19.4.14
- v19.4.15
- v19.4.16
- v19.4.17
- v19.4.18
- v19.4.19
- v19.4.2
- v19.4.20
- v19.4.21
- v19.4.22
- v19.4.23
- v19.4.3
- v19.4.4
- v19.4.5
- v19.4.6
- v19.4.7
- v19.4.8
- v19.4.9
- v19.5.0
- v19.5.0-rc1
- v19.5.0-rc2
- v19.5.0-rc3
- v19.5.0-rc4
- v19.5.0-rc5
- v19.5.1
- v19.5.2
- v19.5.3
- v20.0.0
- v20.0.1
- v20.0.10
- v20.0.11
- v20.0.12
- v20.0.13
- v20.0.14
- v20.0.15
- v20.0.16
- v20.0.17
- v20.0.18
- v20.0.19
- v20.0.2
- v20.0.20
- v20.0.3
- v20.0.4
- v20.0.5
- v20.0.6
- v20.0.7
- v20.0.8
- v20.1.0
- v20.1.0-rc1
- v20.1.0-rc2
- v20.1.0-rc3
- v20.1.0-rc4
- v20.1.0-rc5
- v20.1.0-rc6
- v20.1.0-rc7
- v20.1.1
- v20.10.0
- v20.10.1
- v20.10.2
- v20.11.0
- v20.12.0
- v20.12.1
- v20.12.2
- v20.2.0
- v20.3.0
- v20.4.0
- v20.5.0
- v20.6.0
- v20.7.0
- v20.8.0
- v20.9.0
- Affected ranges
- ECOSYSTEM: < 20.12.3
Update to 20.12.3
Original sources
- https://github.com/OpenMage/magento-lts/security/advisories/GHSA-5pxh-89cx-4668
- https://github.com/OpenMage/magento-lts/commit/d307e5bf75729a2347dde0952fe9fd9fcd9c6aea
- https://github.com/OpenMage/magento-lts/releases/tag/v20.12.3
- https://github.com/OpenMage/magento-lts/releases/tag/v20.13.0
- https://nvd.nist.gov/vuln/detail/CVE-2025-27400